[Bug] Property Bind != Add Node in Play mode

FlowCanvas Forums Support [Bug] Property Bind != Add Node in Play mode

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #2665

    Hi, I believe I found a bug with FlowCanvas.
    Unity 2019.4.1f1
    FlowCanvas 3.0.9

    I can not add any new nodes when in Play mode. Right clicking/Space bar opens up the Add Node search bar but nothing shows up. It is just stuck on “Loading…” and the blue fill stays at the minimum. This only occurs in Play mode and not outside.

    To reproduce the bug:

    1. Create a game object (I created a 3D Object -> Cube)
    2. Add Component -> FlowScript Controller
    3. Create New -> Bound, on the FlowScript Component.
    4. Add Variable for the Game Object blackboard -> Bound (Self) -> Transform -> Position.
    5. Enter Play Mode and try adding a node.

    That’s all. When binding to a property, tried other ones as well, rigidbody properties, colliders, etc. It just stops letting you add nodes in Play Mode. And there are no errors in any of the consoles.

    I haven’t missed something have I? My first time using flow canvas.



    Thank you for the reproduction steps. I can confirm that this is indeed a bug (and it was a very weird one as well).
    I have however fixed this now and I am attaching for you here the fixed package.
    Please let me know if things work properly for you after you import the package.

    Join us on Discord: https://discord.gg/97q2Rjh

    You must be logged in to view attached files.

    Thank you! That solved that problem.

    Another “issue”. Not sure if by design. When adding something like AddForce/AddTorque in playmode and referring to Self. The rigidbody instance does not resolve automatically, you have to select the instance yourself. When doing so in Edit Mode though, and going from edit to Play mode, it resolves it for you.

    Is that something that can be fixed? Running an extra resolve when in editor playmode and adding nodes referring to Self?


    Hello again,

    Thanks. I am glad this solves the previous issue.
    Regarding adding node in play mode and “self”, “self” is set when initializing the graph which is done one when the graph starts. I will take a look at making it possible to have “self” resolve at any time and thus adding a node in playmode will properly resolve “self” as well.
    Thanks for pointing that out! 🙂

    Join us on Discord: https://discord.gg/97q2Rjh

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.